Customer Engagement & Dynamics CRM Forum

 View Only
Expand all | Collapse all

Relevance Search fields do not match Quick Find View

Jump to Best Answer
  • 1.  Relevance Search fields do not match Quick Find View

    Posted 24 days ago
    Hi, 

    For our Account records, I was trying to set it up so that the account owner would show as the secondary field in the Relevance Search. I placed the Owner field next to the primary field (Account Name) in our Quick Find View. 

    However, the relevance search is not updating and continues to show either Address1:City or Primary Contact.




    I think this might have to do with the solution layers of the Quick Find view, but I'm not sure what to do. Currently, there's a system layer and an unmanaged layer. Both have a fetch xml listing the City and Primary Contact fields as one of the first fields after Account Name. I tried deleting the unmanaged layer, but when I add the Owner field to the view it gets re-created. Does anyone know how I can work around this?  


    Side note - We moved our CRM from on-prem to the cloud earlier this year, so I'm not sure if that would have any effect on this.

    Thanks in advance,





    ------------------------------
    *************
    Rachel Merino
    Red River
    *************
    ------------------------------



  • 2.  RE: Relevance Search fields do not match Quick Find View
    Best Answer

    Posted 23 days ago
    Hello Rachel,

    I've seen this happening in our environment as well and was just as confused. After some fiddling around I created a support ticket with Microsoft and they suggested the following steps to resolve the issue:

    • Navigate to Advanced Settings -> Customizations -> Customize the system ->Entity (this has to be done in the classic interface. No idea why 😊) 
    • Select the Entity and go to Views
    • Open Quick Find View
    • Remove all columns except the first , then Save and Close and Publish all customizations
    • Open Quick Find View again and add the second columns which want to see in search, then save and close and publish all customizations.
    • Open Quick Find View again and add all other columns , then save and close and publish all customizations.
    • By following these steps the issue is resolved.

    Cheers!





    ------------------------------
    Thomas van de Vosse
    Virtual Vaults
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role