Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

XRM Toolbox Connection Issues

  • 1.  XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 8 days ago
      |   view attached
    Calling any and all XRM Toolbox experts....I have been using XRM Toolbox on D365 9.1.0.5229 without issues until my AzureAD password changed, now I am not able to connect using any of my current connections (with updated password) or by creating new ones.  I am getting the error attached to this post when using the connection wizard (which worked fine before the password change).  Any idea how to correct this issue?  Most of the articles I've read about this error points to a mis-match between server and client time, this is Online D365, so how could I check servertime from online?????

    ------------------------------
    Lance Day
    Systems Analyst, CRM
    Dunbar Armored
    Carlisle PA
    ------------------------------

    Attachment(s)

    CRMUG Summit - Post


  • 2.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 7 days ago
    Hi Lance,
    What version of XrmToolBox are you using?
    Have you tried connecting using the SDK Login Control?

    Jonas

    ------------------------------
    Jonas Rapp
    MVP, Enterprise Architect
    Sweden
    ------------------------------

    CRMUG Summit - Post


  • 3.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 7 days ago
    It might be obvious but, as I don't think you say, can you connect properly in a browser and login to these environments/instances/organisations?

    ------------------------------
    Andrew Wolfe
    Head of CRM Practice
    Technology Services Group
    United Kingdom
    ------------------------------

    CRMUG Summit - Post


  • 4.  RE: XRM Toolbox Connection Issues

    Posted 7 days ago

    Hi Lance,

    This post gives a solution to check server time: https://social.microsoft.com/Forums/en-US/76267dd9-0529-4bb1-8150-498cb1c1a87f/how-to-get-the-server-time-in-dynamics-crmonline653116531165311?forum=crmdevelopment

    just have to go to this page : https://<orgname.onlinezone>.dynamics.com/test/crmtest.aspx

    I don't know if this is a cause of your issue cause server time is not the same as my client time, and I do connect to XrmToolbox without any issues.

    Yet I did already had connection errors due to different time between client an server. This was due to the client having a wrong time.

    Best regards,



    ------------------------------
    Laurent Maneville
    N Media
    Drummondville QC
    ------------------------------

    CRMUG Summit - Post


  • 5.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 7 days ago
    Hello All, and thank you for your input.  To answer a few of these questions; yes I can connect to the instances without issue, I am using version 1.2019.6.33 and the server / client times are in sync.  What Also happened that I did not know, between my password being reset is that the network team went to a MFA on me!!  Which did in fact cause the authentication issue.  Even after following the steps from XRMToolbox to connect with MFA it still failed, soooo, I just cheated and used a service account that is not MFA required and password does not expire for the connection!  Solved!

    Thanks again all.

    ------------------------------
    Lance Day
    Systems Analyst, CRM
    Dunbar Armored
    Carlisle PA
    ------------------------------

    CRMUG Summit - Post


  • 6.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 7 days ago
    Sneaky! 😉🤫

    ------------------------------
    Jonas Rapp
    MVP, Enterprise Architect
    Sweden
    ------------------------------

    CRMUG Summit - Post


  • 7.  RE: XRM Toolbox Connection Issues

    TOP CONTRIBUTOR
    Posted 6 days ago
    Lance,

    I had the same issue and worked around it the same way by using a non MFA account when using the XrmToolBox.  When researching the issue did you try to register the application in your Azure environment?  I tried but never got it to work, it keeps prompting me to login about 200x a session.

    Does anyone know if there is something in the works to make the XrmToolBox MFA compliant?

    Thanks,

    Jim

    ------------------------------
    Jim Corriveau
    A.W. Chesterton Company
    Groveland MA
    ------------------------------

    CRMUG Summit - Post


  • 8.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 6 days ago
    Hi Jim,

    I did try to register an app in Azure, however in XRMToolBox there is a line that requires a Reply URL, and I think that step has either been removed or replaced in Azure in one of the last updates as there is no where that I can see to set a Reply URL when registering an app.  When I got to that point is when I basically gave up and went the easy route with a non-mfa account. :)

    ------------------------------
    Lance Day
    Systems Analyst, CRM
    Dunbar Armored
    Carlisle PA
    ------------------------------

    CRMUG Summit - Post


  • 9.  RE: XRM Toolbox Connection Issues

    SILVER CONTRIBUTOR
    Posted 6 days ago
    Perhaps @Tanguy Touzard can help with this?​

    ------------------------------
    Jonas Rapp
    MVP
    Sweden
    ------------------------------

    CRMUG Summit - Post


  • 10.  RE: XRM Toolbox Connection Issues

    MVP DE MICROSOFT
    Posted 6 days ago
    I will check how app registration changes and see if it needs adjustment on my side.
    waiting for this, you can use SDK logon control. Should work

    ------------------------------
    Tanguy Touzard
    Javista

    ------------------------------

    CRMUG Summit - Post


If you've found this thread useful, dive deeper into User Group community content by role