Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

UCI Performance

  • 1.  UCI Performance

    SILVER CONTRIBUTOR
    Posted Nov 19, 2019 12:00 PM
    Hi all,

    We're migrating over to UCI and some testers have said they find it slower than the classic interface when loading dashboards and views and opening individual records.

    I was surprised to hear this as I really limited what's available in their model-driven app in terms of entities, views, charts, forms etc. and other users, myself included, have found it to be quicker.

    Has anyone had a similar experience?

    Thanks in advance,

    ------------------------------
    Sean O Malley
    AIG
    ------------------------------
    Academy - Online Interactive Learning from Experts


  • 2.  RE: UCI Performance

    Posted Nov 20, 2019 03:25 PM
    Hi Sean,
    I wonder if there are differences in the browsers being used by the users saying it's slow versus you and the others saying it's faster, or if they are experiencing issues on initial load but not noticing it's much quicker once things are cached.  You haven't mentioned how explicit you've been to the testers, but I've encountered customers where users assume they should still use IE with CRM because they had to 5 years ago, or where users complain about speed on those initial loads but don't revise their opinions when it's much faster from then on.  That may or may not be the issue. Also, where possible, I always suggest using a tool that can measure in real values/time to evaluate performance instead of user opinion - it's much easier to identify issues if you have concrete data and can evaluate changes than a user saying it "seems slow".

    ------------------------------
    Merlin Schwaiger
    Director of Solution Design
    PowerObjects, an HCL Company
    Minneapolis MN
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 3.  RE: UCI Performance

    SILVER CONTRIBUTOR
    Posted Nov 22, 2019 12:26 PM

    Hi Merlin,

    Everyone is using Chrome and running on similar hardware and they've been on the new interface for over a week so caching shouldn't be an issue.
    I'll do some further investigation and open a support ticket if I don't come up with anything.

    Thanks for your response



    ------------------------------
    Sean O Malley
    AIG
    ------------------------------

    Academy - Online Interactive Learning from Experts


If you've found this thread useful, dive deeper into User Group community content by role