Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Lookup vs.. Add new record on Custom entity

  • 1.  Lookup vs.. Add new record on Custom entity

    SILVER CONTRIBUTOR
    Posted 13 days ago
    Hello.
    I have a custom entity. On it, I have a subgrid of that same record type to build a parental view. When I click the "+" to search for an existing record, it opens a new form to add a new type of that record. I would like it instead to open the in-line lookup so I can add an already-existing record. I have seen some information on how to do this with differing record types, but have been unable to find out what I am missing when it is the same entity type.

    How can I get it so it gives me a lookup and not try to enter a new record?

    If you need more details, let me know.

    Thanks!

    ------------------------------
    Joe Vekich
    SICK, Inc.
    Bloomington MN
    ------------------------------
    Conference-CRMUG_200x200


  • 2.  RE: Lookup vs.. Add new record on Custom entity

    TOP CONTRIBUTOR
    Posted 12 days ago
    The '+' button on a subgrid is strictly for new records, not for adding existing records.  To add an existing record, you would need to navigate to the 'Related' area where you should be able to find the 'Add Existing' button.

    Hope this helps!

    ------------------------------
    Chris Harrington
    Solutions Architect
    PowerObjects, an HCL Company
    ------------------------------

    Conference-CRMUG_200x200


  • 3.  RE: Lookup vs.. Add new record on Custom entity

    SILVER CONTRIBUTOR
    Posted 12 days ago
    Thanks, Chris -

    However, I do get this functionality on a different subgrid.
    "Account Conditions" is an entity that is N:1 to Accounts. I found that is I make the "Account" field required on the Account Condition, I got the "New" screen. If it is not required, I get the Lookup.

    So, in this case, I am adding the same record type: "Global Account Data". There is a "Parent Global Account Data" field that feeds this subgrid, and it is not required like my previous example. I would think that means I get the Lookup, not the "New" screen.

    Basically, I followed what I read in this post, but it does not seem to apply if the subgrid is the same record type:

    https://www.crmug.com/communities/community-home/digestviewer/viewthread?MessageKey=fd9a4ad1-1850-481b-bac7-e4a63be36056&CommunityKey=dc83c23b-ede0-4070-ae7a-dd90859148a6&tab=digestviewer


    ------------------------------
    Joe Vekich
    SICK, Inc.
    Bloomington MN
    ------------------------------

    Conference-CRMUG_200x200


  • 4.  RE: Lookup vs.. Add new record on Custom entity

    TOP CONTRIBUTOR
    Posted 12 days ago
    Ok, I think I misunderstood then.  You may be correct that adding something from the same entity won't work. You'd have to go to the 'target' child record, and set the parent there.

    Good Luck!

    ------------------------------
    Chris Harrington
    Solutions Architect
    PowerObjects, an HCL Company
    ------------------------------

    Conference-CRMUG_200x200


If you've found this thread useful, dive deeper into User Group community content by role