Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Custom view isn't pulling through information about certain entities

  • 1.  Custom view isn't pulling through information about certain entities

    Posted 8 days ago
    Hi there,

    I have created a view in CRM and for some reason, the branch and phone number part of the view isn't pulling through the information.  Can anyone offer some information on why that might be - or where I need to look to diagnose the issue?

    The entitiy I am starting from is an email open record from Clickdimensions.

    Kind regards




    ------------------------------
    Laura Janaway - Marketing Manager
    Grafton Support Services
    Oxford
    ------------------------------
    Conference-CRMUG_200x200


  • 2.  RE: Custom view isn't pulling through information about certain entities

    Posted 7 days ago
    @Laura Janaway I would look into the Schema names of the fields where the data is entered and ensure those are the fields on your view. A great tool for this is "Level up d365 Google Chrome Extension" there is a button in the tool called "show logical names" which will place the logical names on the form. If this isn't a tool you can get, the form editor is a native solution to retrieving this information and verifying the schema names.

    ------------------------------
    Erik Seitz
    RJ Corman Railroad Group, LLC
    Nicholasville KY
    ------------------------------

    Conference-CRMUG_200x200


  • 3.  RE: Custom view isn't pulling through information about certain entities

    Posted 7 days ago
    Hi Erik,

    Thanks for your quick response.  The schema name is the correct one.  The tool you recommended didn't work for me but I identified it by looking in the field properties when you select what fields you want to pull into a view.

    It seems that from the sent email record that information from the contact entity pulls through but not if I look up again to the customer entity.

    Any ideas?

    ------------------------------
    Laura Janaway
    Grafton Support Services
    Oxford
    ------------------------------

    Conference-CRMUG_200x200


  • 4.  RE: Custom view isn't pulling through information about certain entities

    Posted 7 days ago
    @Laura Janaway You may need to also check the relationship between the two entities and make sure that the mapping from the source field to the destination field is set. From your description it sounds as though the information resides on the source entity but not the destination, and the destination is the source you are using on your view.

    ------------------------------
    Erik Seitz
    RJ Corman Railroad Group, LLC
    Nicholasville KY
    ------------------------------

    Conference-CRMUG_200x200


  • 5.  RE: Custom view isn't pulling through information about certain entities

    TOP CONTRIBUTOR
    Posted 7 days ago
    @Laura Janaway - are you trying to show information about the Contact parent Account?
    Does the Account field actually exist on the entity you are trying to report on?
    OOB, you can only report on direct relationships (i.e. parent) and not on grandparent relationships.

    Not Possible: Email Open => Contact => Account
    Possible: Email Open => Contact Account

    Apologies if this is not what you are trying to do?

    ------------------------------
    Donal McCarthy
    Digital Marketing Administrator
    BrightWork
    Galway
    ------------------------------

    Conference-CRMUG_200x200


  • 6.  RE: Custom view isn't pulling through information about certain entities

    SILVER CONTRIBUTOR
    Posted 5 days ago
    To elaborate on what others said:

    If the field you are trying to pull is two entities away:
    • you will not be able to display it on a view
    • make sure you have the relationship to the entity you want fields from
    • and the relationship mappings to support that. 
    I have this issue on some of mine as well.  There are two ways to go about this once the three above suggestions are in place:
    1. use a workflow to populate the field on create and update (I'm sure a Flow would achieve this just fine as well)
    2. use JavaScript on the form to query the OData to populate the field (you will have to have the field on the form for this to work)

    Hope that helps

    ------------------------------
    Jessica Learned
    CRM IS Technical Analyst
    Pyrotek
    Spokane WA
    ------------------------------

    Conference-CRMUG_200x200


If you've found this thread useful, dive deeper into User Group community content by role