Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Google Chrome and Dynamics 365 issue

  • 1.  Google Chrome and Dynamics 365 issue

    Posted 27 days ago
    My organization uses Dynamics 365 on-prem and a lot of our sales staff uses Chrome books when they are mobile. It seems like this week, CRM has run fairly slow and some entities aren't loading at all in Chrome, but appear to be fine in other browsers. Anybody have similar experience or links to best practice to optimize some CRM speed outside of the basics?

    ------------------------------
    Michael Rushton
    StoneMor Partners
    Trevose PA
    ------------------------------


  • 2.  RE: Google Chrome and Dynamics 365 issue

    GOLD CONTRIBUTOR
    Posted 27 days ago
    Hi Michael, I have seen slow performance of our instance on chrome as well however we are online (not on-prem).

    ------------------------------
    Sunil Raheja
    Aha Apps
    Glen Allen VA
    ------------------------------



  • 3.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 24 days ago
    We've seen so many different problems with the Chrome Browser in the last three months that we have moved all our users onto other browsers.

    Problems have included everything from the single quote around downloaded files, unable to step through records, records just not loading first time, but then loading after a refresh, and general slow response

    I know it's not very helpful to suggest a different browser for Chrome Books, unless you can run a different browser on it?

    I know Microsoft are redeveloping Edge on Chromium, so that may be an option?

    ------------------------------
    Simon West
    Nett Sales LLP
    Aldbourne
    ------------------------------



  • 4.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 24 days ago
    We are online, and we're seeing quite a few issues. One that has been bugging me as admin is that I've been having to clear cache to get back into some of the Security settings. I can usually get to the Users entity once or twice but then the next time it'll just spin. Only thing I have figured out that fixes it is clearing cache. Has happened with more entities than just Users and it's frustrating!

    Unfortunately, with some third party tools that we use, Chrome is really what is compatible. Hoping we see some improvement soon!

    ------------------------------
    Julie Reynolds
    Enterprise Information Steward II
    Brotherhood Mutual Insurance
    Fort Wayne IN
    ------------------------------



  • 5.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 23 days ago
    @Simon West Chromium Edge may help in the future, but since it's based on the Chrome engine, it may just be the case that the issues are present in two browsers, rather than one. :) In fact, I've seen the same issues in Chromium Edge until about a week ago when 77.0.189.3 was released.

    My only hope is that the UUI addresses some of the oddities with Chrome / Chromium and that once we've migrated to it, the problems will reside (or at least become less frequent).

    ------------------------------
    Steve Platz
    Technical Lead, Commercial Excellence
    LORD Corporation
    Cary NC
    ------------------------------



  • 6.  RE: Google Chrome and Dynamics 365 issue

    GOLD CONTRIBUTOR
    Posted 23 days ago
    Maybe this is Microsoft's way of saying it is time to switch to the new Unified Interface?

    ------------------------------
    Jon Meyer
    Chief Technology Officer
    CAPFinancial Partners, LLC
    Raleigh NC
    ------------------------------



  • 7.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 24 days ago
    Michael

    We're on premise and we have started to notice some strange issues in Chrome - For example we cannot open up the system users list under settings.  Works in IE but not chrome unless your clear the cache - then it will work for a bit and then stop again.  For us it is mainly causing issues in the Settings Area viewing Mailboxes or teams etc.​

    ------------------------------
    James Rees
    Senior Systems Engineer
    Liverpool John Moores University
    Liverpool
    ------------------------------



  • 8.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 24 days ago
    I'm not sure this is limited to OnPrem.  Just had the same problem getting into settings > security OnLine too.  Clearing the cache works once then back to the spinning wheel.

    Straight in on Edge.  Very odd...

    ------------------------------
    Simon West
    Nett Sales LLP
    Aldbourne
    ------------------------------



  • 9.  RE: Google Chrome and Dynamics 365 issue

    GOLD CONTRIBUTOR
    Posted 24 days ago
    Hi,

    Yes, it seems that Chrome 72.0 has broken the export (adding ' to the file name)
    Chrome  >= 74.x has broken the loading of the files.

    We are running onPrem 8.2.2 and see those issues.
    We have updated one of our dev environment from 8.2.2 to 8.2.7 and I don't see the issues anymore on this environment.

    See more info about those cumulative updates here https://support.microsoft.com/en-us/help/3142345/microsoft-dynamics-365-onpremise-cumulative-updates.

    You might want to install the updates or switch browsers

    Thanks

    ------------------------------
    Christian J. Betrisey
    Software Developer
    American College of Emergency Physicians
    Irving TX
    ------------------------------



  • 10.  RE: Google Chrome and Dynamics 365 issue

    Posted 24 days ago
    Thanks everyone for the replies and info!

    ------------------------------
    Michael Rushton
    StoneMor Partners
    Trevose PA
    ------------------------------



  • 11.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 24 days ago
    I'm so glad its not just me. I've been going crazy this past week trying to figure it out. We're running 8.2 on prem with Chrome 75.

    ------------------------------
    Gretchen Garcia
    IT Technician
    Denver Public Library
    Denver CO
    ------------------------------



  • 12.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 23 days ago
    We've been seeing some similar issues to what others are reporting as well when we got the 9.1.0.5626 update this past weekend.

    Most users cleared their cache and everything was fine but we had a few users that didn't solve their issues.  What we found was that they need to go to the Advanced Tab when clearing data from Chrome and checking all the boxes fixes their issues and it appears to hold for them as well when they log back in the next day.




    ------------------------------
    Eric Veneziano
    Sales System Analyst
    Minitab, Inc.
    State College PA
    ------------------------------



  • 13.  RE: Google Chrome and Dynamics 365 issue

    Posted 21 days ago
    We're facing the same problems with google chrome and MS CRM on-prem 8.2. When the records taking long time just reloading the page again will make that record load fast. And we are also experiencing adding ' to the downloaded file name.

    ------------------------------
    Ram Kiran Yarramasu
    Aha Apps
    Glen Allen VA
    ------------------------------



  • 14.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 21 days ago
    There is a Chrome plugin to fix the single quote in the downloaded files:

    Customer Engagement & Dynamics CRM Forum - Dynamics CRM User Group
    Crmug remove preview
    Customer Engagement & Dynamics CRM Forum - Dynamics CRM User Group
    Hidden page that shows all messages in a thread
    View this on Crmug >


    ------------------------------
    Simon West
    Nett Sales LLP
    Aldbourne
    ------------------------------



  • 15.  RE: Google Chrome and Dynamics 365 issue

    Posted 20 days ago
    Hi Michael,

    We're using Dynamics 365 online and seems to have encountered issue with record loading, admin settings loading, etc on Chrome. Was actively configuring forms and from time to time the form/field property dialog just won't load and I had to switch to IE. Can confirm there are no updates to Chrome (by policy) so assuming this must be Dynamics?

    Hopefully it all goes back to normal next week.

    Regards,
    Jacky

    ------------------------------
    Jacky Chen
    Consultant
    Chamonix Consulting
    ------------------------------



  • 16.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 20 days ago
    I've been going back and forth with multiple Microsoft support tickets and in the most recent exchange, I have found some initial success with using the beta version of Chrome, version 76.0.3809.x.

    With Chrome, version 75.0.3770.x I'm still seeing the spinning loading icon on many of the pages like Settings > Security, Users and even one under Business Management.

    I would be interested in knowing if others have also used the beta version of Chrome and if this made a difference.

    Regards,

    Bob


    ------------------------------
    Robert Chang
    CRM Application Developer
    Cystic Fibrosis Foundation
    Bethesda MD
    ------------------------------



  • 17.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 20 days ago
    I had been experiencing the spinning screens in the settings area (especially on Users and Business Units) but it hasn't happened for several days. I'm currently on version 75.0.3770.X. I don't know what version I was on last week when I was experiencing difficulties.

    ------------------------------
    Julie Reynolds
    Enterprise Information Steward II
    Brotherhood Mutual Insurance
    Fort Wayne IN
    ------------------------------



  • 18.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 20 days ago
    Edited by Gretchen Garcia 20 days ago
    So I just downloaded Canary to test. I have version 77.0.3837.0  x64. All of the hang up screens I was seeing, I am not seeing it any more. We are using on-prem 8.5.2. 

    (edited to change the version - I copied it from the wrong window) :P
    ------------------------------
    Gretchen Garcia
    IT Technician
    Denver Public Library
    Denver CO
    ------------------------------



  • 19.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 15 days ago
    Last week, I didn't have any problems getting stuck spinning on the admin settings, users, etc. This week, the problem is back. I also experienced it in IE, though. I was doing a lot of changes to user roles, so I was in and out of user records frequently. When Chrome started spinning, I switched over to IE until it started spinning. Perhaps this is a bigger issue with Dynamics. Anyone else see the issue outside of Chrome?

    ------------------------------
    Julie Reynolds
    Enterprise Information Steward II
    Brotherhood Mutual Insurance
    Fort Wayne IN
    ------------------------------



  • 20.  RE: Google Chrome and Dynamics 365 issue

    SILVER CONTRIBUTOR
    Posted 15 days ago
    Thank you for confirming.  We decided to ask our users to keep switching between Chrome, Firefox, Edge and IE until Microsoft fixes things.  We believe it may be more trouble than it's worth having them use beta versions of browsers.

    Anyone use Vivaldi or Opera with D365 on a regular basis?

    Bob



    ------------------------------
    Robert Chang
    CRM Application Developer
    Cystic Fibrosis Foundation
    Bethesda MD
    ------------------------------



  • 21.  RE: Google Chrome and Dynamics 365 issue

    Posted 14 days ago
    I have been having a lot of issues accessing advanced settings using chrome, I have found that ms edge works fine.

    ------------------------------
    Benjamin Terebelo
    Madison CRES
    ------------------------------



  • 22.  RE: Google Chrome and Dynamics 365 issue

    Posted 2 days ago
    We are using Dynamics 365 Cloud v 9.x and experiencing the same issues with the latest Chromium. It started by not loading settings screens at first and now random users are reporting the same issue when using CRM. Clearing cache is a temporary fix only it seems. Edge preview seems fine but its a few chromium versions behind.

    ------------------------------
    mihai catalina
    WhiteWater West Industries, Ltd
    Richmond BC
    ------------------------------



  • 23.  RE: Google Chrome and Dynamics 365 issue

    GOLD CONTRIBUTOR
    Posted yesterday
    We were experiencing the same issue with our On-Premise environment. Microsoft suggested we use this version of chrome since there is a know issue with Version 75.0.3770.100

    Below is the link provided by Microsoft to Chrome 76

    https://www.google.com/chrome/beta/




    ------------------------------
    Krishna Jacques
    CRM Specialist
    Rumsey Electric Company
    conshohocken PA
    ------------------------------



  • 24.  RE: Google Chrome and Dynamics 365 issue

    TOP CONTRIBUTOR
    Posted 21 hours ago
    Hi Krishna,
    thank you for sharing the link. As we also experience some of the above mentioned issues with Chrome I downloaded the Beta 76 and the issue with the not loading customer entities is solved but the issue with the qhotation marks around the downloaded files is not solved. I guess we need to wait and see what the future provides.
    Just for the records we are using CRM 365 Version 1612 (8.2.3.8) on prem.

    ------------------------------
    Axel Girgensohn
    Dynamics CRM Specialist
    Aller Media AB
    ------------------------------



  • 25.  RE: Google Chrome and Dynamics 365 issue

    Posted 12 hours ago
    I regularly ask my users to try out different browsers whenever there are inexplicable problems such as these. Some of my users swear by IE for Dynamics. The latest issues with certain settings screens I also worked around by using Edge.

    ------------------------------
    Sissy Bottcher
    Client Success Manager
    StudyPortals
    Eindhoven
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role