Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Business Rules not working after deployment

  • 1.  Business Rules not working after deployment

    Posted 10 days ago
    ​Business Rules are not working after deployment. I have to deactivate and activate Business rule again to make it work.
    I do not know the reason why this is happening? Anyone in CRM user group faced the same issue.

    regards


    ------------------------------
    Jeebo Mathews
    Agricorp
    ------------------------------


  • 2.  RE: Business Rules not working after deployment

    TOP CONTRIBUTOR
    Posted 10 days ago
    Did you manually create any fields in the production environment, or are you certain they were all created through an imported solution?
    Are you referencing any teams or queues in the business rules?

    I have seen cases where a team or a queue is created manually in the sandbox and also in production. This makes it appear that they right data is in both places, but they actually have distinctly different GUID's. So when you create a workflow or business rule, it will reference the other records (such as a team) using its GUID instead of the actual name, and then when you deploy it, it will not work.

    If that is the case, then you will have to make a copy of your production environment to a new development sandbox. After that, I recommend you use the Data Transporter tool in XRMToolbox to migrate Queues and Teams (in that order) from your Dev, to Staging and Production environments.

    ------------------------------
    Nelson Johnson
    Solution Architect
    BroadPoint, Inc.
    Bethesda MD
    Link with me! https://www.linkedin.com/in/nelsonjohnson/
    ------------------------------



  • 3.  RE: Business Rules not working after deployment

    TOP CONTRIBUTOR
    Posted 7 days ago
    Also - what kind of deployment was this? What version are you on?

    When we first upgraded to CRM 2016, we had a lot of issues with Business Rules not firing. The fix was related to security role change. Check out the details here: https://readyxrm.blog/2017/05/01/dynamics-crm-business-rules-not-working-issue/

    ------------------------------
    Kylie Kiser
    Supervisor, CRM System
    Fairfax VA

    www.CRMUG.com/Washington
    ------------------------------



  • 4.  RE: Business Rules not working after deployment

    Posted 6 days ago
    Another thing to check is Legacy Form Rendering. I had some strange issues with one of our business rules that was caused by Legacy Rendering. Good luck!

    ------------------------------
    Greg Enns
    ERP Coordinator
    Technical Prospects
    Kaukauna WI
    ------------------------------