Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Hyperlinks to CRM Records

  • 1.  Hyperlinks to CRM Records

    GOLD CONTRIBUTOR
    Posted Feb 01, 2019 03:26 PM
    I have an unusual issue and have been unable to find a solution online.  Hoping the CRMUG may have some insight.  I use Dynamics online.

    For small data sets, I tend to analyze them in Excel.  If I happen to have the GUIDs for the CRM records, I use a macro to assign direct hyperlinks-which is easier than searching in the system using advanced find, views, etc.  To assign the hyperlinks, I use this format (blue text are variables):

    https://company.crm.dynamics.com/main.aspx?etn=entity&id={GUID}&pagetype=entityrecord

    An issue, however, appeared this morning.  Links that previously worked from Excel (or Word) are returning the following error message:


    If I copy/paste the link into the browser, it returns the proper entity record.  I looked at the security settings, but nothing jumps out.

    Anyone have thoughts on what could be causing this?

    Thanks!

    ------------------------------
    Kyle Buggie
    Columbus OH
    ------------------------------


  • 2.  RE: Hyperlinks to CRM Records

    SILVER CONTRIBUTOR
    Posted Feb 01, 2019 03:43 PM
    Hey Kyle - not sure if this is related, but we've been having problems with saved browser shortcuts to CRM not working, starting today. I did notice that we received a service update last night, and suspect that may have caused this issue.

    ------------------------------
    Brian Mergen
    Morton Buildings, Inc.
    Morton IL
    ------------------------------



  • 3.  RE: Hyperlinks to CRM Records

    GOLD CONTRIBUTOR
    Posted Feb 01, 2019 04:46 PM
    Thanks Brian!  We have noticed some users complaining about defective bookmarks, too.  I did not see anything in the service update notes, but I am going to submit a ticket to MS anyway.

    ------------------------------
    Kyle Buggie
    Columbus OH
    ------------------------------



  • 4.  RE: Hyperlinks to CRM Records

    TOP CONTRIBUTOR
    Posted Feb 04, 2019 07:45 AM
    @Brian Mergen you might have just saved my week! On Friday, we started having some users unable to access the system. Some were able to get in using a different browser than normal and others still couldn't. Baffling to say the least. Your comment about the bookmarks/favorites got me thinking that might be our problem. Some users just copied the url from their failed attempt to use their bookmark in one browser to try to access using another browser.

    It all makes sense to how some of our users work. I had a user unable to access the system yet this morning, so I tried sending her directly to the url and not through her favorite....we got right in!!

    Once again, this community is much appreciated!

    ------------------------------
    Julie Reynolds
    Enterprise Information Steward II
    Brotherhood Mutual Insurance
    Fort Wayne IN
    ------------------------------



  • 5.  RE: Hyperlinks to CRM Records

    SILVER CONTRIBUTOR
    Posted Feb 04, 2019 08:57 AM
    Hi @Julie Reynolds ​. Glad I could help!

    ------------------------------
    Brian Mergen
    Morton Buildings, Inc.
    Morton IL
    ------------------------------



  • 6.  RE: Hyperlinks to CRM Records

    TOP CONTRIBUTOR
    Posted Feb 01, 2019 10:52 PM
    What is the default browser and its version?

    ------------------------------
    Nelson Johnson
    Solution Architect
    BroadPoint Technologies, LLC
    Bethesda MD
    ------------------------------



  • 7.  RE: Hyperlinks to CRM Records

    Posted Feb 04, 2019 01:35 AM
    Uh oh this is bad news for us, we're using the Marketing module for events and imported about 9000 events that we're slowly fixing. We're using a similar dynamic hyperlink and so far it's still working but it'd be a bummer if it stopped :)

    ------------------------------
    Mike Prill
    Team Rubicon USA
    Los Angeles CA
    ------------------------------



  • 8.  RE: Hyperlinks to CRM Records

    GOLD CONTRIBUTOR
    Posted Feb 04, 2019 09:09 AM
    Hi Nelson, I am on Chrome 71, but confirmed the issue exists in Chrome 72, Edge, etc.  I have a ticket opened with Microsoft.  We will see what they say.

    ------------------------------
    Kyle Buggie
    Columbus OH
    ------------------------------



  • 9.  RE: Hyperlinks to CRM Records

    TOP CONTRIBUTOR
    Posted Feb 05, 2019 04:57 AM
    I use the below in Power BI and it is working fine

    Lead Link = "https://crminstance.crm.dynamics.com/main.aspx?etc=4&extraqs=&histKey=637399322&id=%7b"& [leadid] &"%7d&newWindow=true&pagetype=entityrecord#225138446"

    See https://www.powerobjects.com/2017/06/30/drill-into-crm-records-from-power-bi/ for a longer explanation. I think the syntax should be reusable.

    ------------------------------
    Donal McCarthy
    BrightWork
    Galway
    ------------------------------



  • 10.  RE: Hyperlinks to CRM Records

    GOLD CONTRIBUTOR
    Posted Feb 05, 2019 09:08 AM
    Edited by Kyle Buggie Feb 05, 2019 09:08 AM
    Hi Donal,

    I was not aware of the different URL convention, but the issue still exists.  You brought up an important point though.  I am NOT encountering this issue in Power BI, Outlook (Office 365), or browser-based apps.  It only seems to appear when I make the jump from a local application (e.g., Excel, Word) to Dynamics.

    Also, Microsoft assessed the ticket and was able reproduce/confirm the issue.  They have escalated it to their development team.  Fingers crossed.

    Thanks!

    ------------------------------
    Kyle Buggie
    Columbus OH
    ------------------------------



  • 11.  RE: Hyperlinks to CRM Records

    GOLD CONTRIBUTOR
    Posted Feb 19, 2019 02:39 PM
    Quick update.  I submitted a ticket to Microsoft, and they claim I was encountering a known defect with Office (not Dynamics).  This is the workaround they offered:

    https://support.microsoft.com/en-us/help/218153/error-message-when-clicking-hyperlink-in-office-cannot-locate-the-inte

    While it did fix the issue on my computer, they could not explain (1) what changed to just now trigger the issue, (2) why Office 365 is not listed in the affected applications, (3) why it is affecting me when one of the "cause" conditions was not satisfied, and (4) how to cascade a fix across my organization.

    I will add more details if anything new is found.

    ------------------------------
    Kyle Buggie
    Columbus OH
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role