Customer Engagement & Dynamics CRM Forum

Expand all | Collapse all

Chrome oddity - Stall/hang on "Loading Business Logic"

  • 1.  Chrome oddity - Stall/hang on "Loading Business Logic"

    SILVER CONTRIBUTOR
    Posted Mar 31, 2019 01:11 PM
    I'm curious if anyone else has noticed this odd behavior in Chrome 73. I've had a number of users tell me their Chrome browser will stall/hang on the Loading Business Logic step when opening a record. It doesn't seem to matter which entity (Contacts, Accounts, custom entities, etc), and if you merely refresh the record will load normally. It also doesn't happen all the time. All this makes me think it's not some javascript or asset on the form that is causing it to hang, rather it's something in the latest version of Chrome.

    Just curious if anyone else has seen this in their organizations.

    Thanks!


    ------------------------------
    Mike Cutlip
    RAMCO
    www.RAMCOAMS.com
    Durham, NC
    ------------------------------
    CRMUG Summit - Post


  • 2.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    GOLD CONTRIBUTOR
    Posted Apr 01, 2019 05:45 AM
    Hello @Mike Cutlip,

    This is a present known issue with Microsoft on Google Chrome browser with v73 being used.

    below is some information from the O365 health page

    O365 Service Health Overview status page 

    Title: Custom entities not rending in Google Chrome version 73

    User Impact: Users may not be able to view entity records when using Google Chrome version 73.0.3683.86.

    More Info: This is impacting only custom entities with a custom handler.

    Impacted users may see a "Loading business logic" screen when attempting to view entity records. This affects creating a new record, opening an existing record, and opening a record from a sub-grid. This issue is not seen in lower versions of Google Chrome and is not seen in other web browsers.


    Current Status: We have identified that, when accessing CRM entity records with the latest version of Chrome (73.0.3683.86), the records will not open. We have developed and are deploying a code fix for this issue. We will incorporate this fix into scheduled service updates during your region's upcoming maintenance window. We will continue to monitor service health throughout this process to and provide an update by the time listed below, or as events warrant.

    User Experience: Users may not be able to view entity records when using Google Chrome version 73.0.3683.86.

    ==========
    For the time being below are the workarounds suggested.

    Workarounds:

    1. Use any other browser
    2. Downgrade to Chrome v72
    3. Add an "onload" handler to the forms.  The "onload" handler doesn't have to do anything; it just needs to exists and that will allow the form to load.


    ------------------------------
    Bhartendu Pandey
    Willis Towers Watson
    London
    ------------------------------

    CRMUG Summit - Post


  • 3.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    SILVER CONTRIBUTOR
    Posted Apr 01, 2019 10:32 AM
    Interesting. Thanks, Bhartendu. I've seen this happen on vanilla CRM entities, as well, but we do have custom handlers. Will research it a bit more with our dev team but this seems likely to be the issue. 


    Mike Cutlip
    RAMCO Director
    919-789-1291
    Join the RAMCO community at http://ramcoams.connectedcommunity.org




    CRMUG Summit - Post


  • 4.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    GOLD CONTRIBUTOR
    Posted Apr 01, 2019 10:41 AM
    Hello @Mike Cutlip.

    I would say the behavior would exist on all entities (although the service health report specifically mentions custom entities). We should try out the workarounds ​and it should be great help till a fix is rolled out.

    ------------------------------
    Bhartendu Pandey
    Willis Towers Watson
    London
    ------------------------------

    CRMUG Summit - Post


  • 5.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    Posted Apr 01, 2019 12:09 PM
    I would submit a ticket to Microsoft. We had the same issue on our Service last week. Microsoft at least for our region said the issue was resolved today and a patch was released today at some point. The issue appears to be resolved for us. I would have users do the general clear cookies and cache, and make sure they are on the latest chrome update if needed.

    Also worth noting this is specifically happening only for the classic UI, this issue doesn't occur on the new UI.

    Hope this helps.

    ------------------------------
    Jefferson Daniel
    Sun Valley Solar Solutions
    ------------------------------

    CRMUG Summit - Post


  • 6.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    GOLD CONTRIBUTOR
    Posted Apr 01, 2019 12:57 PM
    This has been happening for our users as well although I haven't heard reports of it today. I noticed we were on Service Update 40 last week (9.1.0.4056), but today we're on 32 (9.1.0.3254). We were downgraded for some reason, either on purpose or because of a scheduling and deployment mistake.

    ------------------------------
    Andy Arndt
    Minitab, Inc.
    State College PA
    ------------------------------

    CRMUG Summit - Post


  • 7.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    Posted Apr 03, 2019 12:34 PM
    Edited by Sara Crowley Apr 03, 2019 12:35 PM
      |   view attached
    Hi Mike,

    My team was having a similar issue.  I sent a ticket into MS and found out it was related to our custom security roles.  If you're using custom security roles, make sure they all have Org Wide Read access on the Action Card permission - in Core Records.  Good luck!

    ------------------------------
    Sara Crowley
    Application Administrator - CRM
    HellermannTyton
    Madison WI
    ------------------------------

    CRMUG Summit - Post


  • 8.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    GOLD CONTRIBUTOR
    Posted Apr 03, 2019 12:41 PM
    Hello Everyone,

    Just checking if anyone has experienced a similar situation in other browsers.. We had a call with Microsoft and they reiterated that this was primarily related  to the Chrome Odd behavior with v73

    Possible fixes
    Downgrade chrome to V72
    Use another browser

    Also from what i could understand a fix is being planned for  the same.

    ------------------------------
    Bhartendu Pandey
    Willis Towers Watson
    London
    ------------------------------

    CRMUG Summit - Post


  • 9.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    SILVER CONTRIBUTOR
    Posted Apr 04, 2019 02:18 PM
    We are seeing the same thing with our on-prem install. While online might get a patch in the next few days as it rolls out, those of us on-prem are not quite so lucky.  I found this thread on the dynamics community page that gave the java script suggestion above but also enabling legacy forms. Since this bug also seems to affect Chrome 74 Canary, I can only expect it's not going to get fixed any time soon. Firefox didn't have the problems for us but our users tend to use Chrome. Enabling the legacy forms did fix it for us and I haven't seen any sort of performance change so far.

    ------------------------------
    Gretchen Garcia
    IT Technician
    Denver Public Library
    Denver CO
    ------------------------------

    CRMUG Summit - Post


  • 10.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    SILVER CONTRIBUTOR
    Posted Apr 04, 2019 04:00 PM
    Thanks, Candace. Since we're also on-prem this is a good option for us to try. 

    I appreciate everyone chiming in on this! Chrome is also my preferred browser but it hasn't played nicely with CRM these past couple months.



    Mike Cutlip
    RAMCO Director
    919-789-1291
    Join the RAMCO community at http://ramcoams.connectedcommunity.org




    CRMUG Summit - Post


  • 11.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    SILVER CONTRIBUTOR
    Posted Apr 09, 2019 09:42 AM
    For those who are on premise, I have been testing the latest patch for Dynamics 365 8.2 and it does appear to resolve some of our issues with Chrome..

    Thanks
    James

    ------------------------------
    James Rees
    Senior Systems Engineer
    Liverpool John Moores University
    Liverpool
    ------------------------------

    CRMUG Summit - Post


  • 12.  RE: Chrome oddity - Stall/hang on "Loading Business Logic"

    TOP CONTRIBUTOR
    Posted Apr 10, 2019 07:25 AM
    All

    Repaired Functionality

    The following list details issues whose resolutions repair items in Dynamics that are not functioning.

    • Knowledge base articles could not be searched in dashboards.
    • Meeting attachments could not be opened after downloading them.
    • A box was misaligned in a dashboard.
    • Entity forms failed to load when using the Chrome browser.


    https://support.microsoft.com/en-us/help/4494402/microsoft-dynamics-365-on-premises-update-2-5

    ------------------------------
    Rex Kenley Tan, MCP
    Tallmadge OH
    https://www.youracclaim.com/users/rex-kenley-tan

    *Always be CURRENT with JavaScript & C#, NEVER be obsolete.

    DISCLAIMER: All views expressed on this site are my own and DO NOT represent the opinions of ANY entity whatsoever with which I have been, am now, or will be affiliated.
    ------------------------------

    CRMUG Summit - Post


If you've found this thread useful, dive deeper into User Group community content by role